Forums > Windsurfing   Gps and Speed talk

2 sec highlight missing in Google earth tracks

Reply
Created by sboardcrazy Two weeks ago, 6 Jun 2019
sboardcrazy
NSW, 6559 posts
6 Jun 2019 11:01AM
Thumbs Up

The 2 sec shows in pink in KA72 but I lose it when I get the track in google Earth. I prefer google Earth. This has only happened in the last few months.
Anyone else got the issue ? How do you fix it?

powersloshin
NSW, 1010 posts
7 Jun 2019 7:52AM
Thumbs Up

Yes I also noted that, but have no idea how to fix it. 6th of April is the last time I had the red 2 sec mark in Google. Tried to update to the latest version , but no difference. In GPS Results I can still see the 2 sec. mark, so I am guessing it could be the way KA72 is creating the google file?

sboardcrazy
NSW, 6559 posts
7 Jun 2019 11:44AM
Thumbs Up

Maybe I should get onto Dylan..

boardsurfr
WA, 794 posts
7 Jun 2019 9:44PM
Thumbs Up

I just looked at your track from June 3rd in Google Earth on my Mac. The top speeds are all highlighted in black. On this particular track, that's more "lowlighting" than highlighting since the background is very dark. But you can click on the 2 sec item in the tracks on the side bar to see where it is:


Thanks for mentioning the issue. I was just looking into adding exports to Google Earth to GPS Speedreader, and this illustrates nicely that the highlighting color should be settable.

boardsurfr
WA, 794 posts
7 Jun 2019 10:14PM
Thumbs Up

No, I had a closer look and that's not the whole issue. The bigger problem is that a top-10 second speed is drawn over the top 2 seconds. If you deselect the top 10 seconds on the left, you can see the top 2 seconds in red. This will probably happen with some, but not all, files, since sometimes the top 2 seconds are not part of a top 10 second run.

If you wanted to, you could open the downloaded KLM file in a text editor, and replace "1" with "12" to have the 2 seconds drawn on top. If you also replace all occurences of "FF000000" with "FF00FFFF", the 10 seconds will be highlighted in yellow:

If you contact Dylan about this, ask him to make the draworder for the 2 seconds the highest, not the lowest, of the top speeds.

sboardcrazy
NSW, 6559 posts
8 Jun 2019 12:21PM
Thumbs Up

Select to expand quote
boardsurfr said..
No, I had a closer look and that's not the whole issue. The bigger problem is that a top-10 second speed is drawn over the top 2 seconds. If you deselect the top 10 seconds on the left, you can see the top 2 seconds in red. This will probably happen with some, but not all, files, since sometimes the top 2 seconds are not part of a top 10 second run.

If you wanted to, you could open the downloaded KLM file in a text editor, and replace "1" with "12" to have the 2 seconds drawn on top. If you also replace all occurences of "FF000000" with "FF00FFFF", the 10 seconds will be highlighted in yellow:

If you contact Dylan about this, ask him to make the draworder for the 2 seconds the highest, not the lowest, of the top speeds.



Thanks. I'll do that.

I usually take print screen shot of the Google earth and then crop it to put in my post. I can't use the sidemenu once it's cropped..?

decrepit
WA, 9180 posts
8 Jun 2019 1:01PM
Thumbs Up

Sue you can't use the side menu in an image, you have to do that while in Google Earth.

sboardcrazy
NSW, 6559 posts
8 Jun 2019 3:21PM
Thumbs Up

Select to expand quote
decrepit said..
Sue you can't use the side menu in an image, you have to do that while in Google Earth.


That's what I thought... I suppose I could fiddle before I take a screenshot but I think I'd prefer it like it was. I'll email Dylan this link.

Tony Wills
NSW, 233 posts
9 Jun 2019 4:26PM
Thumbs Up

Love a challenge - thanks again Boardsurfr.

What's better is when it actually works

Come on Sue! It's easy!!!




decrepit
WA, 9180 posts
9 Jun 2019 3:13PM
Thumbs Up

That looks much better!! Love those colours, the divisions really stand out, I've been struggling to see them in the old colours.
(Although Peter, the 10s should be orange not yellow, to match our jelly beans)

Pity the gybe ended up in the NM though

sboardcrazy
NSW, 6559 posts
12 Jun 2019 1:47PM
Thumbs Up

Select to expand quote
boardsurfr said..
No, I had a closer look and that's not the whole issue. The bigger problem is that a top-10 second speed is drawn over the top 2 seconds. If you deselect the top 10 seconds on the left, you can see the top 2 seconds in red. This will probably happen with some, but not all, files, since sometimes the top 2 seconds are not part of a top 10 second run.

If you wanted to, you could open the downloaded KLM file in a text editor, and replace "1" with "12" to have the 2 seconds drawn on top. If you also replace all occurences of "FF000000" with "FF00FFFF", the 10 seconds will be highlighted in yellow:

If you contact Dylan about this, ask him to make the draworder for the 2 seconds the highest, not the lowest, of the top speeds.


Dylans onto it but I thought I'd change the colours.
ok I opened it in notepad and got gobbly gook. How do I get html..?



decrepit
WA, 9180 posts
12 Jun 2019 6:34PM
Thumbs Up

Select to expand quote
sboardcrazy said..

ok I opened it in notepad and got gobbly gook. How do I get html..?



Sue, download the sublime text editor.

boardsurfr
WA, 794 posts
12 Jun 2019 8:56PM
Thumbs Up

Notepad should be able to opem .kml files (although you may be better of with a nicer editor like Notepad++, free at notepad-plus-plus.org).

It looks like you clicked on the "Download" link instead of the KML link, and dowloaded the .sbn or .sbp file. Should be easy to find out by checking the extension (look at the "Properties" if your OS is hiding known extensions).

sboardcrazy
NSW, 6559 posts
13 Jun 2019 7:31AM
Thumbs Up

Select to expand quote
boardsurfr said..
Notepad should be able to opem .kml files (although you may be better of with a nicer editor like Notepad++, free at notepad-plus-plus.org).

It looks like you clicked on the "Download" link instead of the KML link, and dowloaded the .sbn or .sbp file. Should be easy to find out by checking the extension (look at the "Properties" if your OS is hiding known extensions).



I didn't have the file on hand so I went to KA72 searched for the session and dowloaded the track.
What extension do I need? I hope to sail today so I can try it as I upload.

AUS4
NSW, 987 posts
13 Jun 2019 7:47AM
Thumbs Up

Forget all this rubbish Sue, leave your GPS at home, go for a sail and enjoy yourself.

sailquik
VIC, 4645 posts
13 Jun 2019 8:24AM
Thumbs Up

.kml

decrepit
WA, 9180 posts
13 Jun 2019 10:22AM
Thumbs Up

Here Sue,

Instead of hitting the "download" button, hit the (KML) button instead. Do Peter's mods, then import it into Google Earth.



sboardcrazy
NSW, 6559 posts
13 Jun 2019 1:12PM
Thumbs Up

Select to expand quote
decrepit said..
Here Sue,

Instead of hitting the "download" button, hit the (KML) button instead. Do Peter's mods, then import it into Google Earth.




I'm doing it by searching for an old file on KA72. I know to click on the KML button. I don't think you get that option when you do a search.

sboardcrazy
NSW, 6559 posts
13 Jun 2019 1:12PM
Thumbs Up

Select to expand quote
AUS4 said..
Forget all this rubbish Sue, leave your GPS at home, go for a sail and enjoy yourself.


Just been sailing..

decrepit
WA, 9180 posts
13 Jun 2019 11:20AM
Thumbs Up

Select to expand quote
sboardcrazy said..
I'm doing it by searching for an old file on KA72. I know to click on the KML button. I don't think you get that option when you do a search.



My image above is from a search I just did.
But I pressed the green, globe button not the download button.




sboardcrazy
NSW, 6559 posts
13 Jun 2019 2:36PM
Thumbs Up

Select to expand quote
decrepit said..


sboardcrazy said..
I'm doing it by searching for an old file on KA72. I know to click on the KML button. I don't think you get that option when you do a search.





My image above is from a search I just did.
But I pressed the green, globe button not the download button.





Dur..
I just did the change with my latest file and it changed the 10sec colour but still no sign of the 2 sec. i might not get around to making further changes for a while as I have work I need to do..







decrepit
WA, 9180 posts
13 Jun 2019 4:55PM
Thumbs Up

so did you replace the 1s with 12s, that's what's meant to bring the 2s on top.

sboardcrazy
NSW, 6559 posts
14 Jun 2019 8:49AM
Thumbs Up

Select to expand quote
decrepit said..
so did you replace the 1s with 12s, that's what's meant to bring the 2s on top.



No. I didn't know I had to do that. I'll try it when I get a chance.
I don't think the 10 sec is obscuring the 2 sec in these tracks..?

decrepit
WA, 9180 posts
14 Jun 2019 9:36AM
Thumbs Up

Yes, that's the most likely explanation, otherwise you'd see it. Have another read of Peter's instructions.

Sue, I've just checked, and that's the case. here's the relevant part of the KML file.
ID="2SecPeak"
Where it says "drawOrder 1", I've changed this to 12 and this is the result. your 2s was under the NM looks like a few of your 5 X 10s are there as well


decrepit
WA, 9180 posts
14 Jun 2019 11:14AM
Thumbs Up

So what happens when I change the NM to 1



Well how about that, the NM sinks to the bottom and the rest of the 10s and the alpha appear. You learn something everyday, thanks Peter.

sailquik
VIC, 4645 posts
14 Jun 2019 7:53PM
Thumbs Up

Select to expand quote
decrepit said..
Yes, that's the most likely explanation, otherwise you'd see it. Have another read of Peter's instructions.

Sue, I've just checked, and that's the case. here's the relevant part of the KML file.

Where it says "drawOrder 1", I've changed this to 12 and this is the result. your 2s was under the NM looks like a few of your 5 X 10s are there as well




Hi Mike and Peter.

I just had a fiddle with my KML file (10hz UBX derived) and can't find either of those phrases in the text.

Namely: ID="2SecPeak" or "drawOrder 1"

I also cant fin these: If you also replace all occurences of "FF000000" with "FF00FFFF", the 10 seconds will be highlighted in yellow:

I can find this: ff0000ff

Can you suggest why my KML file looks different? (Opened in text editor on my Mac)

boardsurfr
WA, 794 posts
14 Jun 2019 6:36PM
Thumbs Up

Select to expand quote
sailquik said..

Hi Mike and Peter.

I just had a fiddle with my KML file (10hz UBX derived) and can't find either of those phrases in the text.

Can you suggest why my KML file looks different? (Opened in text editor on my Mac)


How did you make the KML file? If you used anything other than ka72.com, then the contents will be different.

sailquik
VIC, 4645 posts
14 Jun 2019 10:06PM
Thumbs Up

Select to expand quote
boardsurfr said..
How did you make the KML file? If you used anything other than ka72.com, then the contents will be different.


Ahh, I think I used GPS-SpeedReader (beta)

sboardcrazy
NSW, 6559 posts
Thursday , 20 Jun 2019 2:22PM
Thumbs Up




decrepit
WA, 9180 posts
Thursday , 20 Jun 2019 3:47PM
Thumbs Up

Well done Sue!!! But I still only see 3, 10s runs and half the alpha is missing. I don't think you changed the NM to 1



Subscribe
Reply

Forums > Windsurfing   Gps and Speed talk


"2 sec highlight missing in Google earth tracks" started by sboardcrazy